Home Forums Power Pivot No Time Gaps Allowed

This topic contains 2 replies, has 2 voices, and was last updated by  jfrizzle 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7709

    jfrizzle
    Participant
    • Started: 1
    • Replies: 2
    • Total: 3

    I’m hoping someone can help with this. I’m having a problem displaying a time interval on my pivot chart where there is no data. I am charting orders by week number for each year. As you can see from the attached picture, there are missing week numbers in my chart which I want to fill in. I have a fact table which I’m using for order count, and it is connected in the data model to a date lookup table with one instance of each date from 2012 thru 2020. As you can see from the chart, I’m missing weeks 10, 11, 13-17, 21, 27, etc. There are no orders for those weeks, however, those weeks are in my data table which is connected in the data model. I would like these dates to show up on my chart’s axis. I am doing this in Excel version 2016.  Oh, and I have already marked the date table as a date table in PowerPivot.

    Attachments:
    You must be logged in to view attached files.
    #7711

    Mike Shellito
    Participant
    • Started: 0
    • Replies: 10
    • Total: 10

    Right click on the chart and select Pivot chart options.  Click the Display tab. Check the box that says “Show items with no data on axis fields”

    #7714

    jfrizzle
    Participant
    • Started: 1
    • Replies: 2
    • Total: 3

    Many thanks!  Gotta love it when it’s an easy fix.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.